If I Currently Have Another Version of ScreenWatch Installed, Will the Newest Version Be Compatible?

Download PDF:  KB0300

Summary
I just purchased the newest version of ScreenWatch but I have an older version installed on my student workstations.  Is the new version and old version compatible?

Details
As is typical with most software products, ScreenWatch is not backward compatible.  When purchasing the newest version, please be sure to uninstall the existing version prior to installing the newest release.  It is critical that both the Monitor (instructor) station and the student stations are updated to the latest release to prevent clients from disconnecting from the Monitor.

Leave A Comment?

This site uses Akismet to reduce spam. Learn how your comment data is processed.